ETH service temporary maintenance
Incident Report for Coinmetro
Resolved
This incident has been resolved.
Posted Mar 08, 2023 - 21:33 UTC
Monitoring
Please be informed that our ETH service is going through a temporary maintenace. This might affect the time of your withdrawals on any ERC20 tokens
Posted Mar 08, 2023 - 15:19 UTC
This incident affected: Withdrawals.