USDC Volatility
Incident Report for Coinmetro
Resolved
USDC trading is now re-enabled.
Posted Mar 14, 2023 - 12:17 UTC
Identified
On-chain transactions (deposits & withdrawals) for USDC remain active, trading and other transactions for USDC have been temporarily suspended due to recent volatility. We understand that this can be a challenging time for everyone, especially liquidity providers who tend to avoid assets with significant price fluctuations, as it may further worsen the situation. We are closely monitoring the situation and will resume USDC trading and transactions once we have a clearer picture of its future prospects.
Posted Mar 11, 2023 - 11:42 UTC
This incident affected: Exchange.