Deposits, Withdrawals and Trading Halted Temporarily
Incident Report for Coinmetro
Resolved
This incident has been resolved.
Posted Oct 09, 2023 - 15:48 UTC
Identified
Our trading platform is currently experiencing technical issues due to which trading, as well as crypto withdrawals and deposits are temporarily unavailable.

Please rest assured that our tech team is working diligently to resolve this situation.

We want to assure you that your funds and personal information are safe, and are not affected by this temporary technical difficulty.
We appreciate your patience and understanding as we are actively working on restoring full functionality to the platform. Stay tuned for further updates from us, and don’t hesitate to reach out to our Support team via 24/7 live chat or hello@coinmetro.com.
Posted Oct 09, 2023 - 11:34 UTC
This incident affected: Deposits, Withdrawals, Exchange, Margin, and Dashboard Swap.