USD ACH Deposits Disabled until 18th April
Incident Report for Coinmetro
Resolved
This incident has been resolved.
Posted Apr 18, 2022 - 17:51 UTC
Monitoring
USD ACH Deposits are temporarily unavailable due to undergoing some maintenance. Please note, you can still deposit USD via wire or credit card methods in the meantime.

We apologise for any inconvenience caused by this.
Posted Apr 14, 2022 - 14:55 UTC
This incident affected: Deposits.