Internal Server Error when using the Desktop Platform
Incident Report for Coinmetro
Resolved
This incident has been resolved.
Posted Mar 28, 2023 - 09:12 UTC
Identified
The issue is identified and a fix is being implemented. Please note, mobile app versions are still working as intended.
Posted Mar 28, 2023 - 02:42 UTC
This incident affected: Exchange.