USDC and ETH Deposits and Withdrawals are temporarily unavailable
Incident Report for Coinmetro
Resolved
This incident has been resolved. USDC and ETH deposits and withdrawals are now enabled again.
Posted Oct 31, 2023 - 13:03 UTC
Identified
Due to some temporary technical issues causing disruption to our services, we have taken precautionary action and disabled both USDC and ETH transactions on all supported chains.

Please be assured that this issue is temporary, and we are working hard on resolving this as quickly as possible.

We apologize for any inconvenience caused by this in the meantime.
Posted Oct 28, 2023 - 10:06 UTC
This incident affected: Deposits and Withdrawals.